Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-22386

libary1.ecl generated 2 workflow items with same id

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.4.2
    • Component/s: eclcc
    • Labels:
      None

      Description

      I executed internal regression with ecl-test query library1.ecl

      When I execute wutool info DALISERVER=. <Wfid> an out of scope order exception is reported.  Here's the output of the wutool:

       

      <Workunit wuid="W20190620-092201">
      <scope scope='' type='global'>
      <attr kind='WhenCreated' value='1561018921370577' formatted='2019-06-20T08:22:01.370Z' unit='ts' ctype='esp' creator='myesp@172.17.0.1' ts='2019-06-20T08:22:01.370Z'/>
      <attr kind='WhenCompiled' value='1561018921383598' formatted='2019-06-20T08:22:01.383Z' unit='ts' ctype='eclcc' creator='myeclccserver@172.17.0.1' ts='2019-06-20T08:22:01.383Z'/>
      <attr kind='WhenStarted' value='1561018922009667' formatted='2019-06-20T08:22:02.009Z' unit='ts' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.010Z'/>
      <attr kind='SizePeakMemory' value='524288' formatted='512.000Kb' unit='sz' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.034Z'/>
      <attr kind='WhenFinished' value='1561018922035038' formatted='2019-06-20T08:22:02.035Z' unit='ts' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.035Z'/>
      <attr kind='TimeElapsed' value='25668887' formatted='25.668ms' unit='ns' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.035Z'/>
      </scope>
      <scope scope='graph1000000001' type='graph'>
      </scope>
      <scope scope='graph1000000001:e5_9' type='edge'>
      <attr kind='IdSource' value='a5'/>
      <attr kind='IdTarget' value='a9'/>
      <attr kind='SourceIndex' value='0'/>
      <attr kind='TargetIndex' value='0'/>
      <attr kind='IsDependency' value='1'/>
      </scope>
      <scope scope='graph1000000001:sg1' type='subgraph'>
      </scope>
      <scope scope='w1' type='workflow'>
      <attr kind='WhenStarted' value='1561018922015199' formatted='2019-06-20T08:22:02.015Z' unit='ts' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.030Z'/>
      <attr kind='TimeElapsed' value='15476431' formatted='15.476ms' unit='ns' ctype='hthor' creator='myeclagent@172.17.0.1' ts='2019-06-20T08:22:02.030Z'/>
      <attr kind='IsScheduled' value='true'/>
      <attr kind='State' value='done'/>
      </scope>

      On examining, the workunit it seems 2 workflow items have been created with the same id.  The zap report is attached.

       

      library1.zip

       

        Attachments

          Activity

            People

            • Assignee:
              ghalliday Gavin Halliday
              Reporter:
              shamser Shamser Ahmed
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: