Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-22264

Use more modern compiler to build centos7 systems

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Scheduled
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.2.18
    • Fix Version/s: None
    • Component/s: Build process
    • Labels:
      None
    • Compatibility:
      Minor

      Description

      Having recently spent a while tracking down an issue that only happened on Centos7 and which turned out to be due to the fact that the implementation of std::regex in gcc 4.8 is know to be unusably buggy, I wondered if it would be smart to use a more modern devtoolset on our centos7 builds. I don't know what the implications are in terms of dependencies of the resulting package though.

      Also Centos6 - I think we do use a more modern toolset to build them, but is it the best one to pick? I think devtoolset2 may only take us to gcc4.8 which (as noted above) is not really a good choice.

        Attachments

          Activity

            People

            • Assignee:
              Michael-Gardner Michael Gardner
              Reporter:
              richardkchapman Richard Chapman
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Due:
                Created:
                Updated: