Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Not specified
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.2.8
    • Component/s: Plugins
    • Labels:
      None

      Description

      Platform build fails on Ubuntu 19.04 which has ICU 63:

      2:44:23 /mnt/disk1/jenkins/workspace/CE-7.2.x-disco-test/CE/ubuntu-19.04-amd64/HPCC-Platform/plugins/unicodelib/unicodelib.cpp: At global scope:
      12:44:23 /mnt/disk1/jenkins/workspace/CE-7.2.x-disco-test/CE/ubuntu-19.04-amd64/HPCC-Platform/plugins/unicodelib/unicodelib.cpp:148:18: error: variable or field ‘doTrimRight’ declared void
      12:44:23 void doTrimRight(UnicodeString & source)
      12:44:23 ^~~~~~~~~~~~~

      even I include unicode/unistr.h it still reports this error.

      There are other similar errors, for example:
      error: ‘Collator’ is not a class, namespace, or enumeration

        Attachments

          Activity

            People

            • Assignee:
              richardkchapman Richard Chapman
              Reporter:
              xwang2713 Xiaoming Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: