Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-21578

Bison 3.3.2 compatibility issues

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 7.2.0
    • Fix Version/s: 7.2.8
    • Component/s: Code Generator
    • Labels:
      None
    • Environment:
      macOS Mojave
      bison (GNU Bison) 3.3.2

      Description

      Trying to build client tools from the latest 7.2.x branch:

      /Users/campda01/Projects/HPCC-Platform/ecl/hql/hqlgram.y:25.1-20: error: deprecated directive, use ‘%define api.prefix {eclyy}’ [-Werror=deprecated]
       %name-prefix "eclyy"
       ^~~~~~~~~~~~~~~~~~~~
      make[2]: *** [ecl/hql/hqlgram.cpp] Error 1
      make[1]: *** [ecl/hql/CMakeFiles/hql.dir/all] Error 2
      make: *** [all] Error 2
      

      This can be worked around by adding -Wno-deprecated to bisonopt in the cmake files if bison's version is >= 3.3.0, but that may not be the proper workaround.

        Attachments

          Activity

            People

            • Assignee:
              dcamper Dan S. Camper
              Reporter:
              dcamper Dan S. Camper
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: