Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-20423

zapgen doesn't fail if credentials aren't provided against ldap enabled system

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.0
    • Component/s: ecl command
    • Labels:
      None

      Description

      Attila Vamos

      I ran the zapgen command against the 160 cluster which is ldap enabled http://10.173.160.101:8010/.

       

      It doesn't look like the zapgen command fails properly.  It tells me that the zap file was downloaded properly even though nothing was downloaded.  

       

      [loch@test zapdir]$ sudo ecl zapgen W20180821-094558 --path ~/zapdir -s 10.173.160.101
      ZAP file written into /mnt/disk1/home/loch/zapdir/ZAPReport_W20180821-094558.zip.
      ✔ complete at 15:47:31
      [loch@test zapdir]$ ls
      ✔ complete at 15:47:33

       

      This is most likely due to curl not failing when no un/pw is provided for an ldap enabled system.

       

      curl -o /mnt/disk1/home/loch/zapdir/ZAPReport_W20180828-154958.zip http://10.173.160.101:8010/WsWorkunits/WUCreateAndDownloadZAPInfo?Wuid=W20180828-154958
      % Total % Received % Xferd Average Speed Time Time Time Current
      Dload Upload Total Spent Left Speed
      0 0 0 0 0 0 0 0 -::- -::- -::- 0

       

      Lorraine Chapman Richard Chapman 

       

       

        Attachments

          Activity

            People

            • Assignee:
              attilavamos Attila Vamos
              Reporter:
              cloln Chris Lo
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: