Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-20208

Need newer version of libcouchbase to work with OpenSSL1.1 / Ubuntu 18.04

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Not specified
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.0
    • Component/s: Plugins
    • Labels:
      None
    • Environment:
      Ubuntu 18.04

      Description

      /home/hpcc-dev/HPCC-Platform/plugins/couchbase/libcouchbase/src/ssl/ssl_common.c:159:18: error: 'SSL_R_MISSING_VERIFY_MESSAGE' undeclared (first use in this function); did you mean 'SSL_R_MISSING_SRP_PARAM'?
      case SSL_R_MISSING_VERIFY_MESSAGE:
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
      SSL_R_MISSING_SRP_PARAM

        Attachments

          Activity

            People

            • Assignee:
              richardkchapman Richard Chapman
              Reporter:
              richardkchapman Richard Chapman
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: