Currently componentName and complex type name are redundant. The itemType attribute is used to name an element type for insert operations. The componentName attribute is probably redundant and itemType could be used instead. Setting the complex type to the correct component name would remove the need for a separate component name attribute. That would also remove the confusion of having two different ways to name the component. The code that finds the component XSD def based on the build set setting in the element would look for itemType instead.