Uploaded image for project: 'HPCC'
  1. HPCC
  2. HPCC-18722

Embedded python plugins should link against ABI-consistent library

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Not specified
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Plugins
    • Labels:
      None

      Description

      See https://stackoverflow.com/questions/39863827/what-is-libpython3-so-compared-with-libpython3-5m-so-built-from-python-3-5-2-sou

      and

      https://www.python.org/dev/peps/pep-0384/

      Might help ensure our plugin works on systems that have a different version of python from the build box.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              richardkchapman Richard Chapman
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: